This project is read-only.

425 Can't open data connection.

Jun 8, 2010 at 4:03 PM

Hello, i have on my local computer startet Filezilla Server. On a remote computer in my LAN i tried to connect with this FTP Lib Client, but then i get an error in the server log:


200 Type set to I
PORT 172,24,16,12,215,196
200 Port command successful
STOR result.xml
150 Opening data channel for file transfer.
425 Can't open data connection.

when i use the filezilla client i get a connection and i can upload files. When i connect with tht FTP Lib Client it creats a directory on the server but there are no files uploaded.
Have anyone an idea?


Jun 9, 2010 at 6:45 PM

Maybe a firewall issue?

Dec 1, 2010 at 5:25 PM
Edited Dec 2, 2010 at 7:22 AM

I too get this error when i try to use it from a server. No problem when I run it from my local computer. This is very annoying and I havent found a way to solve it, so really hope you can help me out. It seems like there is a problem with getFile() or deleteFile() methods?

Its not an firewall problem because the is at the moment no firewall enabled.

If I start up the program on the server it will run for about a minute or so before it will crash with the same message as above

Dec 2, 2010 at 3:35 PM

Try switching to PASV and see if that works. If it does, then I can take a look at the GetFile() method.

Dec 3, 2010 at 7:14 AM

Hi Scott

I just checked. Both the Crmserver and the FTP server is in passive mode. It’s a strange thing because my project with the getFile and DeleteFile methods is working fine in a minute or so, where it is transferring XML files from FTP to CRM server as it should, but suddenly this error comes up.

I tracked it to following code:

FtpFileInfo[] ftpFiles = ftp.GetFiles();

foreach (var file in ftpFiles)



ftp.GetFile(file.Name, false);

if (readFile(_ftplocal + file.Name))






So if you can do some magic. It would really save my weekend.

Venlig Hilsen

Casper Schau

C2-R logo

Casper Schau

CRM Konsulent


Tolbodgade 16 st.

DK-6000 Kolding


+45 3168 1300


+45 3168 1304


C2R Gold Partner

Fra: scottmeyer []
Sendt: 2. december 2010 16:36
Til: Casper Schau
Emne: Re: 425 Can't open data connection. [ftplib:215333]

From: scottmeyer

Try switching to PASV and see if that works. If it does, then I can take a look at the GetFile() method.

Read the full discussion online.

To add a post to this discussion, reply to this email (

To start a new discussion for this project, email

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at

Dec 21, 2010 at 1:50 PM

Now I tried to set it to passv mode but it didnt help :(